Pages Menu
Categories Menu

Formula excel somma progressiva

Una delle richieste che spesso richiedono gli utenti di Excel è quello relativo a una formula o una macro VBA che consenta di ottenere una “somma progressiva”. L’esigenza è spesso quella di sommare progressivamente il contenuto di alcune celle consecutive senza però dover ricorrere ad un’altra colonna in cui applicare la funzione somma.

Per capirci meglio, ecco una immagine che spiega meglio la situazione e il risultato che vogliamo ottenere:

Nella colonna A abbiamo una serie di numeri (possono anche non essere consecutivi), mentre in B abbiamo il risultato che è una somma progressiva dei numeri presenti nella colonna A.

Come si ottiene il risultato della somma progressiva della colonna B?

La prima soluzione è inserire la seguente formula in B1 e trascinare giù: =SOMMA(INDIRETTO(“A1:A”&RIF.RIGA())) oppure basta la formula SOMMA($A$1:A1)

La seconda soluzione è invece tramite codice VBA. Per fare questo premi i tasti ALT+F11 e apri l’editor delle macro VBA
Clicca due volte sul nome del foglio interessato che trovi a sinistra e incollaci il seguente codice:

Sub MacroSomma()
Range(“B2”).Select
ActiveCell.FormulaR1C1 = “=+RC[-1]+R[-1]C[-1]”
Range(“B3”).Select
ActiveCell.FormulaR1C1 = “=+RC[-1]+R[-1]C”
Range(“B3”).Select
Selection.AutoFill Destination:=Range(“B3:B8”)
Range(“B3:B8”).Select
End Sub

Si tratta di un codice di un codice macro semplice, che ti permette di capire come è avvenuta la somma incrementale. Ovviamente la macro va modificata secondo i range del proprio foglio Excel.

Conosci altri metodi più efficaci per ottenere una somma parziale/cumulativa in una colonna di un foglio excel?

 

Invia Commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *